UPS performance issues
Incident Report for EasyPost
Resolved
The incident has been resolved by UPS
Posted Jul 25, 2024 - 12:29 PDT
Identified
UPS has confirmed that there is a service issue with the UPS API. They are actively working on resolving the issue.
Posted Jul 25, 2024 - 11:06 PDT
Investigating
We are investigating performance issues and timeouts affecting UPS shipments.
Posted Jul 25, 2024 - 10:23 PDT
This incident affected: Carriers (UPS).