Delays to async processes

Incident Report for EasyPost

Resolved

Service has continued to operate normally. This incident is resolved.
Posted Jun 03, 2026 - 11:46 PDT

Monitoring

EasyPost has identified and addressed the issue. We will continue to monitor.
Posted Jun 03, 2026 - 10:57 PDT

Investigating

Async processing of updates and events are currently delayed. EasyPost is investigating the issue.
Posted Jun 03, 2026 - 10:28 PDT
This incident affected: EasyPost Backend (API).