UPS API Rate Limiting

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 13:19 PST

Monitoring

UPS shipments (rating) may be experiencing delays or errors due to API rate limitations on UPS's side. We're working directly with UPS to resolve this issue. If you receive a 'Too Many Requests' error, please retry your request.
Posted Dec 02, 2025 - 08:06 PST
This incident affected: Carriers (UPS, UPSDAP, UPS SurePost, UPS Mail Innovations).