DHL eCS Carrier Outage

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 09:06 PST

Identified

EasyPost is currently experiencing issues with all shipment functions related to DHL eCS due to an outage on their API. We are actively investigating the issue and are in communication with DHL eCS to resolve it.

We will provide updates as more information becomes available.
Posted Dec 10, 2025 - 08:57 PST
This incident affected: Carriers (DHL eCommerce Solutions).