Purolator outage
Incident Report for EasyPost
Resolved
Purolator reports that they have resolved their outage.
Posted Apr 28, 2020 - 13:28 PDT
Identified
Purolator is currently experiencing an outage upstream for some services. EasyPost engineers are monitoring the situation.
Posted Apr 28, 2020 - 08:54 PDT
This incident affected: EasyPost Backend (API).