USPS issues
Incident Report for EasyPost
Resolved
Everything has been stable for the past hour.
Posted Jun 30, 2020 - 17:47 PDT
Monitoring
Engineers have resolved a database contention issue and USPS should be fully operational now. Engineers are monitoring the situation.
Posted Jun 30, 2020 - 16:48 PDT
Investigating
Engineers are investigating issues rating and purchasing postage with USPS
Posted Jun 30, 2020 - 16:39 PDT
This incident affected: EasyPost Backend (API).