Elevated Error rates with FedEx

Incident Report for EasyPost

Resolved

EasyPost experienced intermittent issues with FedEx label purchases due a system update. That update has been fully reverted at this time and normal service operations have resumed. The elevated failure rate was present from 10:40am - 12:00pm US/Eastern
Posted Jul 18, 2025 - 11:39 PDT

Monitoring

The mitigation has been fully deployed and error rates have returned to normal. We are continuing to monitor and will update if the situation changes.
Posted Jul 18, 2025 - 09:09 PDT

Identified

The issue has been identified and mitigations are being deployed. Error rates are decreasing.
Posted Jul 18, 2025 - 09:03 PDT

Investigating

We're seeing elevated error rates with FedEx rating and label buys. We are currently investigating.
Posted Jul 18, 2025 - 08:52 PDT
This incident affected: Carriers (FedEx).