Degraded API Performance

Incident Report for EasyPost

Resolved

All API operations have returned to normal.
Posted Jul 09, 2026 - 11:28 PDT

Identified

The issue has been identified and are working on resolving it.
Posted Jul 09, 2026 - 11:24 PDT

Update

We are continuing to investigate this issue.
Posted Jul 09, 2026 - 11:20 PDT

Investigating

We are experiencing degrading API performance. We are investigating root cause.
Posted Jul 09, 2026 - 11:18 PDT
This incident affected: EasyPost Backend (Webhooks, API, Tracking, Address Verification) and Website.