Degraded UPS API performance
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted Jul 03, 2024 - 19:11 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2024 - 17:53 PDT
Update
We are seeing a return to normal performance for most customers. A small number of customers continue to be impacted. We are working to fully resolve the remaining issue.
Posted Jul 03, 2024 - 14:52 PDT
Identified
The issue has been identified as an issue on the EasyPost side connecting to UPS. A fix has been made and we are seeing performance improvements.
Posted Jul 03, 2024 - 13:43 PDT
Update
We are continuing to investigate this issue.
Posted Jul 03, 2024 - 12:39 PDT
Investigating
The UPS API is experiencing high rates of errors and timeouts for rating, labels, and tracking. UPS has been notified and our engineers will continue to monitor the performance of the UPS API.
Posted Jul 03, 2024 - 12:15 PDT
This incident affected: Carriers (UPS, UPSDAP, UPS SurePost, UPS Mail Innovations).