Elevated API Error Rates
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted Jun 21, 2024 - 14:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2024 - 13:36 PDT
Investigating
We are currently investigating this issue.
Posted Jun 21, 2024 - 13:09 PDT
This incident affected: EasyPost Backend (Webhooks, API, Tracking, Address Verification) and Label Purchases (USPS Postage Purchases).