Scheduled Maintenance for Osm Worldwide V2

Scheduled for Mar 9, 17:00 - 17:30 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 04, 2026 - 15:06 PST

Scheduled

We will be performing scheduled maintenance on parts of our infrastructure starting Monday, March 9th at 5:00 PM PT (8:00 PM ET, Monday, March 9th). Maintenance is expected to conclude by Monday, March 9th at 5:30 PM PT (Monday, March 9th at 8:30 PM ET).

During this window, we expect service disruption of up to 10 min for OSM Worldwide V2
Posted Mar 04, 2026 - 15:05 PST
This scheduled maintenance affects: EasyPost Backend (API).