Elevated error rate
Incident Report for EasyPost
Resolved
There have been no subsequent issues since 15:39 PDT.
Posted Jul 13, 2020 - 15:59 PDT
Monitoring
Engineers have rolled back a problematic deployment and all systems are now fully operational. Engineers will continue to monitor.
Posted Jul 13, 2020 - 15:39 PDT
Investigating
Engineers are currently investigating an elevated error rate
Posted Jul 13, 2020 - 15:35 PDT
This incident affected: EasyPost Backend (Webhooks, API, Tracking, Address Verification) and Website.