Degraded performance
Incident Report for EasyPost
Resolved
This issue has been resolved and we are continuing to monitor.
Posted Aug 12, 2020 - 09:20 PDT
Monitoring
Engineers have implemented a fix and we are recovering. We are continuing to monitor the situation.
Posted Aug 12, 2020 - 08:42 PDT
Identified
Engineers have identified the issue and are working a resolution.
Posted Aug 12, 2020 - 08:24 PDT
Investigating
Engineers are looking into degraded performance.
Posted Aug 12, 2020 - 07:48 PDT