OSM Worldwide tracking outage
Incident Report for EasyPost
Resolved
OSM Worldwide tracking updates are flowing again.
Posted Feb 22, 2021 - 09:34 PST
Monitoring
The carrier OSM Worldwide is experiencing a tracking outage. Our engineers are monitoring the situation.
Posted Feb 19, 2021 - 09:54 PST