Elevated error rates from USPS Label Broker service
Incident Report for EasyPost
Resolved
The service appears to have recovered. Engineers will continue to monitor its performance.
Posted Jun 05, 2022 - 00:18 PDT
Monitoring
USPS service appears stable and engineers are monitoring. Any previously failed label broker requests should be retried.
Posted Jun 05, 2022 - 00:01 PDT
Investigating
USPS is experiencing elevated failure rates in the Label Broker Service. Engineers are investigating.
Posted Jun 04, 2022 - 22:30 PDT
This incident affected: Carrier Rating (USPS).