Batch jobs delayed
Incident Report for EasyPost
Resolved
All batch jobs are caught up
Posted Jul 28, 2021 - 09:35 PDT
Investigating
Batch shipment creation and other asynchronous jobs are currently somewhat delayed due to elevated load. Engineers are investigating.
Posted Jul 28, 2021 - 08:30 PDT