FedEx degraded performance
Incident Report for EasyPost
Resolved
This has been stable for over an hour and we now consider this incident resolved.
Posted Jan 25, 2022 - 14:23 PST
Monitoring
This seems to be resolved as of approximately 13:00 Pacific time. Engineers continue to monitor.
Posted Jan 25, 2022 - 13:03 PST
Identified
FedEx's backend is currently experiencing intermittent spikes of slow performance, affecting EasyPost rating and purchase on FedEx carrier accounts
Posted Jan 25, 2022 - 12:36 PST
This incident affected: EasyPost Backend (API).