Elevated error rate for postage label purchases
Incident Report for EasyPost
Resolved
Engineers have rolled back a change in production and label purchasing is proceeding normally. If you are still seeing errors attempting to purchase shipments, please contact support@easypost.com.
Posted 11 months ago. Nov 16, 2018 - 17:14 PST
Update
We are continuing to investigate this issue.
Posted 11 months ago. Nov 16, 2018 - 17:10 PST
Investigating
We are seeing an elevated rate of errors while purchasing postage labels. Engineers are investigating.
Posted 11 months ago. Nov 16, 2018 - 16:36 PST
This incident affected: API.