Delays in tracking updates
Incident Report for EasyPost
Resolved
This incident has been resolved. Tracking updates are back to normal.
Posted Aug 26, 2024 - 05:33 PDT
Monitoring
Tracking updates are now occurring on schedule. The EasyPost team is monitoring to ensure stability.
Posted Aug 26, 2024 - 04:40 PDT
Identified
The EasyPost team has identified an issue causing delays in tracking updates to customers. We have implemented a fix and service is in the process of normalizing.
Posted Aug 26, 2024 - 04:29 PDT
This incident affected: EasyPost Backend (Tracking).