FedEx Manifesting Issues
Incident Report for EasyPost
Resolved
FedEx manifesting has been stable for over 30 minutes. We consider this
incident resolved but will continue to monitor its performance.
Posted Jun 08, 2024 - 17:42 PDT
Investigating
FedEx is currently experiencing degraded performance affecting manifesting. Our engineers will continue to monitor the performance of the API. FedEx has been notified and our engineers will continue to monitor the performance of the API. Our next update will be
02:28  UTC (7:28pm PST) or sooner.
Posted Jun 08, 2024 - 16:33 PDT
This incident affected: Carriers (FedEx).