UPS performance issues

Incident Report for EasyPost

Resolved

Engineers have resolved the issue and will continue to monitor the service
Posted Jun 06, 2025 - 06:37 PDT

Update

We are continuing to investigate this issue.
Posted Jun 06, 2025 - 06:36 PDT

Investigating

EasyPost is seeing issues with the UPS. We are investigating and communicating with UPS and will provide updates. We apologize for the inconvenience.
Posted Jun 06, 2025 - 04:33 PDT
This incident affected: Carriers (UPS, UPSDAP).