UPS rating - degraded performance
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted May 04, 2023 - 18:56 PDT
Monitoring
The issue has been identified and a fix has been deployed. Engineers are monitoring the performance of the service for further degradation.
Posted May 04, 2023 - 17:55 PDT
Investigating
UPS rating is experiencing degraded performance affecting all users. Engineers are investigating the cause.
Posted May 04, 2023 - 17:04 PDT