Issues with Shipments and Trackers

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 11:41 PST

Monitoring

Issue has been resolved and we will continue to monitor.
Posted Nov 12, 2025 - 09:54 PST

Update

A fix has been put in place. Service is beginning to normalize.
Posted Nov 12, 2025 - 09:16 PST

Identified

Some users are currently unable to retrieve shipments and trackers. The EasyPost team has identified the root cause and is working on a resolution.
Posted Nov 12, 2025 - 08:26 PST
This incident affected: EasyPost Backend (API, Tracking).