Elevated FedEx Label Purchase error rate

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Oct 14, 2023 - 07:51 PDT

Monitoring

The FedEx API has been operating normally for approximately 15 minutes. Engineers continue to monitor the performance of the FedEx API and will update this page as needed.
Posted Oct 13, 2023 - 18:37 PDT

Investigating

We are currently investigating an issue purchasing FedEx labels.
Posted Oct 13, 2023 - 18:02 PDT