Elevated error rate
Incident Report for EasyPost
Resolved
Everything was back to normal as of 10:50 PDT / 17:50 UTC.
Posted Jun 26, 2020 - 12:10 PDT
Monitoring
We have found the problem with USPS rating and the service is recovering.
Posted Jun 26, 2020 - 10:52 PDT
Investigating
Address Verification remains fixed, but USPS rating is showing additional issues.
Posted Jun 26, 2020 - 10:37 PDT
Monitoring
We have resolved an issue that was causing elevated error rates and timeouts for USPS rating and Address Verification. Engineers are monitoring.
Posted Jun 26, 2020 - 10:26 PDT
Investigating
Engineers are investigating elevated timeouts and errors from our backend, possibly related to address verification
Posted Jun 26, 2020 - 10:13 PDT
This incident affected: EasyPost Backend (API, Address Verification).