FedEx Outage

Incident Report for EasyPost

Resolved

FedEx is fully operational
Posted Jul 12, 2022 - 08:50 PDT

Monitoring

FedEx's upstream APIs are coming back online; engineers are monitoring.
Posted Jul 12, 2022 - 08:40 PDT

Investigating

FedEx is currently experiencing an outage affecting rating and label purchase. Engineers are investigating.
Posted Jul 12, 2022 - 08:10 PDT
This incident affected: EasyPost Backend (API) and Carriers (FedEx).