Canada Post Degraded Service
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 17:28 PDT
Monitoring
CanadaPost via Twitter: We are currently experiencing issues with our website and some of our online tools. We apologize for any inconvenience and are working to restore full access.

EasyPost is experiencing an increase in errors from the Canada Post API when rating packages and creating shipments. We will continue monitoring the situation.
Posted Jun 01, 2023 - 14:01 PDT
This incident affected: Carrier Rating (Canada Post).