DHL eCommerce International Manifesting Issues
Incident Report for EasyPost
Resolved
DHL eCommerce's International closeout systems are back online
Posted Oct 19, 2020 - 15:45 PDT
Investigating
Engineers are investigating a possible upstream outage of manifesting/closeout with DHL eCommerce International
Posted Oct 19, 2020 - 14:25 PDT
This incident affected: EasyPost Backend (API).