USPS Label Broker Outage
Incident Report for EasyPost
Resolved
The incident has been resolved, and it has been ~55mins since the last observed Label Broker error. USPS Label Broker® is fully operational.
Posted Dec 13, 2024 - 11:53 PST
Monitoring
We have received an update from the downstream USPS Label Broker® service that they have implemented a fix, and we have been seeing successful responses. We are continuing to monitor the situation.
Posted Dec 13, 2024 - 11:28 PST
Identified
We have received an update from the downstream USPS Label Broker® service that they are working on resolving this issue on their end, and we are monitoring for updates.
Posted Dec 13, 2024 - 10:59 PST
Investigating
An outage is being investigated with the USPS Label Broker service.
Posted Dec 13, 2024 - 10:29 PST
This incident affected: Carriers (USPS).