Reports of FedEx Outage

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Aug 24, 2015 - 13:55 PDT

Update

The latest timeouts seem to be gone, and we haven't seen an SSL error from them in about 16 hours.
Posted Aug 24, 2015 - 11:15 PDT

Update

Many FedEx rate requests are currently timing out. We're investigating if this is related to the SSL issue we've been monitoring on their end or something new.
Posted Aug 24, 2015 - 10:38 PDT

Update

We're still seeing SSL errors connecting to certain FedEx backend servers on about 5-20% of requests. Repeated attempts to enlist FedEx's help to resolve the issue have been fruitless so far. We're continuing to monitor but because we're seeing this across the board on our end, and only on a small percentage of requests on FedEx's end, we still believe the cause is a misconfiguration of a subset of FedEx's Web Service backends.
Posted Aug 22, 2015 - 20:55 PDT

Update

FedEx is now returning an error message beginning with "Remote EJB method: getRates not called. Unable to create the remote bean..." that you'll see occasionally in your shipment.messages after creation. We've brought this to their attention but no resolution or commitment has been made as of yet.
Posted Aug 18, 2015 - 18:07 PDT

Monitoring

We're receiving empty responses from FedEx to about 20% of our requests, the remainder appear to be going through correctly. We'll continue to monitor but it does not appear to be an issue with any of EasyPost's systems.
Posted Aug 17, 2015 - 09:30 PDT

Investigating

We've received reports from customers unable to buy FedEx shipments due to an outage on FedEx's end.
Posted Aug 17, 2015 - 09:11 PDT