Issues purchasing labels using FedEx Default/Wallet Acounts

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 23:19 PST

Monitoring

The issue has been resolved. Label buy functionality for FedEx Default and Wallet accounts has been restored. Customer provided FedEx accounts were not impacted.
Posted Nov 13, 2025 - 17:53 PST

Investigating

This issue is impacting FedEx Default (Wallet) accounts only. Customer provided FedEx accounts are not impacted. We are investigating.
Posted Nov 13, 2025 - 14:39 PST