Degraded API Performance

Incident Report for EasyPost

Resolved

Everything has been stable since 15:28; this incident is resolved.
Posted Apr 01, 2020 - 18:16 PDT

Monitoring

We found the problematic requests that were causing the delays. We are monitoring the situation further; requests for reports remain delayed however.
Posted Apr 01, 2020 - 15:42 PDT

Investigating

The EasyPost API is currently experiencing increased latency for some users. Engineers are investigating.
Posted Apr 01, 2020 - 15:09 PDT
This incident affected: EasyPost Backend (API).