Carrier Maintenance

Scheduled for Nov 4, 23:00 - 23:30 PST

Update

In preparation for peak season, the EasyPost team will be increasing capacity to one of our critical services that certain carrier integrations rely on. During this maintenance, customers may experience several minutes of service disruption for those carriers.
Posted Oct 30, 2025 - 12:06 PDT

Scheduled

In preparation for peak season, the EasyPost team will be increasing capacity to one of our critical services that certain carrier integrations rely on. During this maintenance, customers may experience several minutes of service disruption for those carriers. The carriers are: Amazon Shipping, Gori, Jitsu, Roadie, UniUni, and Veho.
Posted Oct 30, 2025 - 11:56 PDT
This scheduled maintenance affects: Carriers (Amazon Shipping, Gori, Jitsu, Roadie, UniUni, Veho).