Elevated error rates with Parcelforce
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 08:32 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2019 - 07:46 PST
Investigating
We are currently investigating elevated error rates with Parcelforce and will update when we have more information.
Posted Nov 15, 2019 - 06:14 PST
This incident affected: API.