Degraded Performance
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted May 23, 2022 - 14:05 PDT
Monitoring
All systems are operational; engineers are monitoring
Posted May 23, 2022 - 12:57 PDT
Investigating
EasyPost is currently experiencing degraded performance and elevated timeouts. Engineers are investigating.
Posted May 23, 2022 - 12:52 PDT
This incident affected: EasyPost Backend (API).