Elevated errors in Tracking

Incident Report for EasyPost

Resolved

At this time, errors have ceased and the Tracking service has returned to normal.
Posted Mar 13, 2026 - 11:38 PDT

Identified

The Tracking service is currently experiencing a heightened volume of errors. EasyPost has identified this as a result of a deployment.
Posted Mar 13, 2026 - 10:44 PDT
This incident affected: EasyPost Backend (Tracking).