Elevated 500 errors

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 07:54 PST

Monitoring

Issue has been identified and resolved. API error rate has recovered to normal levels. Will continue to monitor.
Posted Mar 03, 2025 - 04:53 PST

Identified

Underlying cause has been identified and a fix is being implemented.
Posted Mar 03, 2025 - 04:50 PST

Investigating

We are experiencing elevated 500 errors on the EasyPost API. We are currently investigating.
Posted Mar 03, 2025 - 04:37 PST
This incident affected: EasyPost Backend (API).