some webhook deliveries currently delayed
Incident Report for EasyPost
Resolved
Webhook deliveries are returning to normal.
Posted Jun 22, 2019 - 21:01 PDT
Investigating
Webhook deliveries are currently delayed for some customers due to a network problem. Engineers are responding.
Posted Jun 22, 2019 - 20:11 PDT
This incident affected: API.