Logging into easypost.com unavailable

Incident Report for EasyPost

Resolved

We identified and resolved the issue. The website is fully operational again
Posted Jun 02, 2026 - 16:16 PDT

Investigating

We are currently investigating issues related to customer's ability to login into easypost.com and manage account.
Posted Jun 02, 2026 - 16:09 PDT
This incident affected: Website.