API issues

Incident Report for EasyPost

Resolved

Service is again stable, with corrections made to prevent recurrence.
Posted Dec 01, 2025 - 12:59 PST

Monitoring

Issue has been resolved and we are currently monitoring
Posted Dec 01, 2025 - 12:38 PST

Identified

We are making some infrastructure updates to mitigate the issue. We expect a momentary disruption as updates take effect.
Posted Dec 01, 2025 - 11:52 PST

Update

Team is still investigating. We are currently seeing delays in asynchronous processes
Posted Dec 01, 2025 - 11:30 PST

Investigating

Team is noticing an uptick in API errors and are investigating.
Posted Dec 01, 2025 - 10:54 PST
This incident affected: EasyPost Backend (API).