Elevated error rate on USPS, UPS

Incident Report for EasyPost

Resolved

Service remains stable. This issue is resolved.
Posted Jun 05, 2026 - 08:16 PDT

Monitoring

Service has normalized. We will continue to monitor.
Posted Jun 05, 2026 - 08:01 PDT

Identified

EasyPost has identified the error and is taking corrective action. Initial indicators are that service is stabilizing.
Posted Jun 05, 2026 - 07:56 PDT

Investigating

We are currently investigating this issue.
Posted Jun 05, 2026 - 07:37 PDT
This incident affected: Carriers (UPS, UPSDAP, UPS SurePost, UPS Mail Innovations, USPS).