Purolator Carrier Outage

Incident Report for EasyPost

Resolved

Purolator reports that all services have been restored.
Posted Mar 13, 2026 - 17:48 PDT

Identified

Purolator has stated that they are experiencing an issue affecting their API services and are working to restore full functionality.

We have observed that error rates with Purolator have improved, but are still higher than average. We are in communication with Purolator and continuing to monitor the situation.
Posted Mar 13, 2026 - 16:49 PDT

Investigating

EasyPost is currently experiencing issues with all Purolator shipment functions due to an outage on their API. We are actively investigating the issue and are in communication with Purolator to resolve it.
Posted Mar 13, 2026 - 13:43 PDT
This incident affected: Carriers (Purolator).