FedEx: Reduced performance and elevated error rates

Incident Report for EasyPost

Resolved

FedEx carrier API performance has returned to normal.
Posted Jan 29, 2026 - 09:58 PST

Identified

We're experiencing reduced performance and increased timeouts/error responses from FedEx APIs.

We've reached out to FedEx and will update this incident when we learn more.
Posted Jan 29, 2026 - 07:05 PST
This incident affected: Carriers (FedEx, FedEx SmartPost).