Elevated UPS error rate
Incident Report for EasyPost
Resolved
Everything has been stable for the last hour. Marking this incident as resolved.
Posted Sep 09, 2020 - 11:28 PDT
Monitoring
UPS has recovered as of approximately 20 minutes ago.
Posted Sep 09, 2020 - 10:57 PDT
Investigating
EasyPost is currently seeing an elevated rate of timeouts and errors from UPS
Posted Sep 09, 2020 - 06:15 PDT
This incident affected: EasyPost Backend (API).