FedEx Elevated Error Rate and Response Times
Incident Report for EasyPost
Resolved
The elevated error rates and response times from the FedEx API have been resolved. Asynchronous processes are caught up.
Posted May 30, 2020 - 14:33 PDT
Monitoring
FedEx has corrected the errors in their API and async processes are catching up now. Engineers continue to monitor for further upstream errors.
Posted May 30, 2020 - 13:41 PDT
Identified
We are currently experiencing elevated error rates and response times communicating with FedEx. Engineers are monitoring and looking into mitigations.
Posted May 30, 2020 - 12:33 PDT
This incident affected: EasyPost Backend (API, Tracking).