USPS Label Broker® Outage
Incident Report for EasyPost
Resolved
This incident has been resolved, and we are seeing successful requests to the USPS Label Broker® service.
Posted Nov 04, 2022 - 16:20 PDT
Monitoring
USPS has confirmed a fix has been implemented and we are monitoring the results.
Posted Nov 04, 2022 - 15:01 PDT
Identified
The USPS has acknowledged the issue and have escalated it to their internal tech team.
Posted Nov 04, 2022 - 14:23 PDT
Investigating
Engineers are currently investigating an outage with the USPS Label Broker® service.
Posted Nov 04, 2022 - 13:08 PDT
This incident affected: Carrier Rating (USPS).