Better Trucks outage
Incident Report for EasyPost
Resolved
The error rate for Better Trucks has subsided. Engineers will continue to monitor the situation and tracking data will continue to update at its normal cadence.
Posted Jun 21, 2022 - 15:53 PDT
Investigating
The Better Trucks carrier is currently experiencing an outage affecting tracking. Engineers are investigating.
Posted Jun 20, 2022 - 12:32 PDT