USPS Label Broker Outage
Incident Report for EasyPost
Resolved
This incident has been resolved, and we are seeing successful requests to the USPS Label Broker service.
Posted Apr 25, 2024 - 20:09 PDT
Monitoring
The USPS has implemented a fix to their LabelBroker service, and we are monitoring the results.
Posted Apr 25, 2024 - 19:16 PDT
Investigating
An outage is being investigated with the USPS Label Broker service.
Posted Apr 25, 2024 - 18:43 PDT
This incident affected: Carrier Rating (USPS).