DAI Post integration degraded

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 15:34 PDT

Monitoring

We have implemented a configuration change at DAI Post's request that should resolve the issue.
Posted Mar 16, 2026 - 15:11 PDT

Identified

A DAI Post SSL certificate expired Mar 15 10:54:27 2026 GMT. This prevents Easypost from securely connecting to DAI Post servers and may block some rating and label purchases.

We are in communication with DAI Post about this issue.
Posted Mar 16, 2026 - 12:28 PDT
This incident affected: Carriers (DAI Post).