Partial API outage

Incident Report for EasyPost

Resolved

Service remains stable and back to normal operation.
Posted May 22, 2026 - 12:02 PDT

Identified

We received automated alerts regarding partial outage to APIs. The team has responded and service is normalizing. Total impact was approximately 5 min.
Posted May 22, 2026 - 11:49 PDT
This incident affected: EasyPost Backend (API).